• This is an archive of ASSEMblerGames.com from June 07th, 2019, all content should be here (minus threads with none english titles, we'll add later.) you cannot login here as this is a clone and your personal info doesn't exist in this database.

    Brought to you by ObscureGamers.

    0th bit/Everdrive forums aren't fully working due to wrong id's from importer. (fixing just takes time) 0th bit posts will be added. Only major issue is the importer copied html/classes which show so need to find a way to strip/convert. this was caused from converting html rips back to SQL. This archive doesn't contain emails/private messages/ip's as we could only convert what google could see/crawl.

Katana (HKT-01) "Failed to detect debug support"

Headcrab

(BigEvilCorporation)


Hi!

This Katana was working, and now it's not. The DA-Check tool complains of:

<div class="bbCodeBlock bbCodeCode">
<div class="type">Code:</div>
<pre>Failed to detect debug support
SALSA report error &lt;SALSA DACON: The full stub failed to load/reset&gt;</pre>
</div> SCSI interface is AHA-2940W, on Windows 2000, with Katana SDK r10.

This machine was working last year when I was doing development on it, but it's been in storage, and now it is not.

Things I've tried so far:
<ul>
[li]Reflash D.A. (using the DA-Check tool, DBFlash won't let me get that far, same error in log)[/li]
[li]Updating SCSI drivers (aspi32.exe)[/li]
[li]Tear down and rebuilt the kit to check for damage (can't see anything)[/li]
[li]Re-seated all removable chips on the board[/li]
[li]Dumped the EPROM, burned image to a fresh M27C160[/li]
[li]Tried another host PC[/li]
</ul> Any tips?

Cheers
 

T_chan

Gutsy Member


Hi,

You pretty much did everything that's to be done...
Other things that I could think of:
- Try with SDK 11 ? (did you use SDK 10 in the past, or SDK 11 ?)
- does the GD-M show up at boot of the SCSI card ? I've had times where a bad GD-M could mess things up
- SCSI settings ? cfr pinned thread <a class="internalLink" href="https://assemblergames.com/threads/how-to-use-the-katana-sdk-on-windows-7.25882/page-2">https://assemblergames.com/threads/how-to-use-the-katana-sdk-on-windows-7.25882/page-2</a>
 

Headcrab

(BigEvilCorporation)


I'll give 11 a go - although I was definitely using 10 in the past.

Yes, both the Katana and GD-M show up on the bus. Windows device manager also shows them as mounted.

I also bit the bullet and ordered another SCSI card, and new terminators. The card wasn't in the machine whilst it was stored away, it was just left out, it may have had a knock or two. I'll run through the SCSI settings from scratch when it arrives.
 


Change the date to 2005 or something? In the past I've seen software not launch and a simple date change on the PC host resolved it.
 

Ioncannon

Rising Member


When you exit da-check you have the option to factory reset. Did you try that? Also try setting to OS Mode if possible. The stub seems to be debug related.
 
Top